I ran into this post (74102654 on SO) as a review audit. It has the tag, though it's not related to Dart. I was about to comment about it, but thought to check its revision history (which at the time of this writing is at revision #6) to see if it was some kind of spam/vandalism edit first. From what I can see, the dart tag has never been in any of the revision history, including the first revision.

According to its Q&A page, its tags are: ,
but according to revision #6, which edited tags, the tags are: .

I don't have the privilege that allows quick tag edits, but when I edit the whole post, the bug manifests (shows dart tag instead of integer-arithmetic tag).

The dart tag also doesn't exist anywhere with the post according to SEDE (reusing a query written by @rene).

Here's a screenshot of the Q&A page, and here's a wayback machine link.

@Zoe gave a look from her end and saw the same thing as me. She suggested it could be due to a bad case of caching. Revision #6 was made on Oct 20th, almost three weeks ago from the date of this writing.

Some SEDE Queries of SO

You can try out the same queries for other network sites. Note: I'm new to SQL so if you want to give me feedback in the SEDE chat room that'd be much appreciated. I've been trying to write a single query that combines most of the above, but am having trouble with the SEDE timeout.

Comparisons with similar bug reports

  • 5
    Cross site duplicate and [status-review]ed on MSO but dealing with a different question also having the [dart] tag Commented Nov 9, 2022 at 19:00
  • 4
    Just to clarify - the issue is not with the [dart] tag itself. Just the two reports happen to have it. It manifests with different tags. The common thing is that there is no history of ever adding the tag, however, it shows up on a post.
    – VLAZ
    Commented Nov 9, 2022 at 19:04
  • 6
    This one has a [scala] "ghost tag" which bumped out a real tag [coldfusion]. It's a much wider issue that appears many places throughout Stack Overflow with many different tags. Commented Nov 9, 2022 at 19:16
  • 1
    There was once a bug, where a post picked as review audit changed the reputation of the selected user, because they actually assigned it instead of cloning the object first. Good chance this is the same bug, from a different direction: when a post is picked as review audit, it affect its tags. Commented Nov 10, 2022 at 8:42

1 Answer 1


I wrote an SEDE query to try and find more occurrences of those "ghost tags" and got some very strange results. The query is not so efficient, so I limited it to 100 results.

Unfortunately, many of these "ghost tags" appear to have been introduced by a rollback for some reason (even though the tag doesn't seem to have ever existed in the question before the rollback). This behavior might be bydesign and/or is a side effect of some operations performed on the those posts (by staff?), so that might need to be discussed in a separate post. Therefore, here's another version of the query excluding those that were caused by a rollback.

I tried to execute the query on other sites to see if the problem has occurred elsewhere, and it seems to indeed have. For example.

  • On Super User, there's a lot of occurrences with the windows-xp tag.
  • On MSE, it happened with 3 posts, two of which don't have a complete revision history and the third one doesn't show any tags under /revisions.
  • 2
    I think many of these older cases (especially the ones here on Meta.SE) are ones where the first revision was hard-deleted from the system as it contained sensitive information. Before the ability for mods to redact content from revisions was introduced, if a post contained sensitive info, staff with DB access would manually purge revisions containing such info from the database. If the first revision (which "added" the tags) was hard-deleted, the revision history won't show any tags (and will also show a different person for the first revision from the actual author). Commented Nov 10, 2022 at 0:33
  • 3
    Old questions are not relevant. Jeff used to meddle directly in the database in the old days, and likely other devs in the early years. So I'd say that until 2012 or so, any such "weirdness" is result of direct meddling of a developer in the database. Can you find only questions posted after 2012 showing that behavior? Commented Nov 10, 2022 at 8:29
  • An example of meddling would be the famous boat programming question (also featured in a podcast episode (at 1 h 02 min 43 secs in episode 50 of the Stack Overflow podcast (now broken), classic series (2009-04-21)).) Commented Nov 3, 2023 at 1:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .