For some reason I can no longer add articles using the "Add Writing" functionality. It used to work ok a while ago. I've been trying to add something lately and I keep getting this annoying error:

error screenshot

As you can see, I'm trying to retrieve a document from google docs, which is shared as public. I had two other documents retrieved in the exact same way a few months back and it worked then, now for the third one it just won't. I even tried to remove one of original two articles and add it again and this time it doesn't let me.

  • Is this only the case with Google docs, or is it the case with any URL? Commented Mar 13, 2012 at 2:59
  • @Nightfirecat: I've also tried with dropbox, but same thing.
    – Tudor
    Commented Mar 13, 2012 at 7:10
  • Is that google doc shared to anyone with the link?
    – user7116
    Commented Mar 14, 2012 at 18:39
  • Yes, it is shared as public. As I mentioned, even documents that could be retrieved before no longer work.
    – Tudor
    Commented Mar 14, 2012 at 18:40

2 Answers 2


Thanks for the report Tudor.

Turns out google docs runs you through some redirects that require you to keep track of cookies and we were getting caught in a redirect loop because we weren't keeping track of the cookies.

This is fixed now.

  • Thanks a lot, works like a charm now.
    – Tudor
    Commented Mar 19, 2012 at 18:03
  • Finding a bug costs you 50 reputation points... :-/
    – user181540
    Commented Mar 19, 2012 at 21:05

First, you need to ensure that such document's setting is "Anyone with the link". If that is correct and no restrictions are applied, then the only suggestion I have is (if you are the owner, or you know the owner) to reset document's settings. Try to reset the link or change settings to other type and then turn it back to "Anyone with the link".

You should also try to use some short url links instead of the original one. There are many available services with such feature. Just google for "short url ". One of them is for example: tinyurl.

  • Thanks. The document is indeed shared as "anyone with the link". I've tried both "resetting" the link and using tinyurl, but it's still not working. :(
    – Tudor
    Commented Mar 19, 2012 at 15:10
  • I am going to ask moderators for diamond input on this...
    – user181540
    Commented Mar 19, 2012 at 15:38
  • 1
    @Tudor: Did you copy the right link? It should contain /view or /edit at the end and /document/ before its long ID. In the same share dialog you should be able to find the link, do not copy the address bar... Commented Mar 19, 2012 at 16:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .