20

This has been reported a long time ago; things might very well have been fixed by now. I can hardly imagine this is a real issue, but maybe it's not too nice for SEO or the data dump? So:

A question on Super User had its comments about duplicates removed by a moderator. However, the "Linked" section still showed the links for many months, until somebody edited an answer:

Linked section still shows the deleted references

Jeff writes that links are cleaned up every 30 days, or whenever a post is edited. The first was not true for this example: the links were definitely still there almost 4 months later (on May 4th 2011). Looking again in October showed the links were okay, but at that time the post had been edited.

I think one link was still used in the 4 close votes that had not expired yet. The other was a link to another duplicate, which might only have been in the comments, not in any vote. (As I voted, I only see "You have already voted to close this question" so cannot validate which duplicates were used. Both links were in my comments.)

This is related to Posts linked in deleted answers still show up under “Linked”, which meanwhile has been tagged status-bydesign. But while 10k can see deleted answers, deleted comments cannot been seen by anyone but moderatos.

9
  • (Just for the record: the comments were deleted over a week ago now, no changes. So if some daily script is supposed to fix this, then something is wrong.)
    – Arjan
    Jan 21, 2011 at 11:32
  • Still linked today, since January 14th. But apparently they are cleaned up every 30 days, or whenever a post is edited. So, hopefully nobody edits — and we should see the links disappear soon now!
    – Arjan
    Feb 15, 2011 at 0:22
  • Note that the linked questions, Explain how the Internet works to a complete computer novice and What happens when you enter a URL in your browser?, do NOT link back to that question that still shows these two links. (Still linked.)
    – Arjan
    Feb 18, 2011 at 11:40
  • (Still linked; still no edits. Another example here on MSO, linking to a FAQ on protected questions in a comment I deleted just today.)
    – Arjan
    Apr 21, 2011 at 8:40
  • Just tested in another question: editing an answer does update the "Linked" section and remove obsolete links. I've not touched the examples mentioned above, just in case they can help troubleshooting the background processes. So: still linked today, still no edits.
    – Arjan
    May 4, 2011 at 11:07
  • Okay, meanwhile an answer on the example from my question was edited, and its "Linked" section is empty now.
    – Arjan
    Oct 30, 2011 at 19:03
  • 1
  • 1
    @Flexo, I don't think it's a dupe. True, it's showing the same behavior, but even there Balpha's answer suggests things are resolved by waiting, like I referred to in my 2nd comment too. But that's not true; things were not fixed until someone edited half a year later.
    – Arjan
    Jul 25, 2012 at 9:57
  • was about to ask this. so question1 has comment linking to question2, after edit of which question does the link get removed?
    – bool.dev
    Nov 16, 2012 at 14:51

1 Answer 1

7

There was a missing call to our sync code here - it will happen appropriately after the next build. What happens typically is one of 2 cases:

  • If you're adding a link, just see if we have that link, add it if not
  • If you're removing or changing a link...we have to re-check all links (you can't just remove it, maybe it was referenced many times, etc.)

Removing a comment wasn't triggering either case, now it will appropriately trigger the second.

3
  • Seems like the "Linked" section might still be outdated when comments are auto-deleted, like here (screenshot 1, and screenshot 2 when an additional link was added).
    – Arjan
    Jul 23, 2013 at 11:52
  • (The stale link I saw in my previous comment, is now gone. Just leaving the comment here in case you want to investigate.)
    – Arjan
    Jul 23, 2013 at 16:28
  • Nick, linking is supposed to be a two-way thing, right? Like if in some post I link to another question, then that other question should show a link back to the first question? If so: that's not working in this question, to which I had to add a comment to link to an answer that linked there. Deleting my comment also makes the "Linked" section disappear again.
    – Arjan
    Dec 26, 2013 at 10:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .