I was voting two comments, and when I was voting the second one, the arrow to vote it vanished.

  • I voted the first comment
  • I voted the second comment, but I did it too fast
  • I clicked on the dialog box saying I have to vote a comment every 5 seconds
  • I tried again to vote, but I forgot the counter has been reset; the dialog box still reminds me of the 5 seconds limit
  • I tried once again, but 5 seconds were not passed
  • I don't see any more the number of votes the comment already received, and the arrow is replaced with a link


I also tried with the first comment on this very question: I clicked the arrow to vote it, and without to wait 5 seconds, I clicked the arrow again. The result is the following one:


If I click on the "upvote" link, what I get is the following:


The votes, including mine, were two; where is now the other vote?

What happened?
If this makes any difference, I am using Safari 5.1.1 on Mac OS X 10.7.2.

When I look at the Safari's "Activity" window, I notice the following events:


  • 11
    Repro with FF7 (partly): Upvoting a comment and immediately clicking the (now bold) arrow again makes it disappear. Oct 27, 2011 at 12:15
  • 5
    I've had this and similar errors a number of times in the past few days. FF8 beta.
    – agf
    Oct 27, 2011 at 12:30
  • 6
    Repro with Chrome as well.
    – JNK
    Oct 27, 2011 at 12:50
  • 4
    Posting a comment to work towards my Pundit badge. Feel free to experiment with this bug using the arrow to the left. Oct 27, 2011 at 13:56
  • 1
    Should I tag this question as bug?
    – apaderno
    Oct 27, 2011 at 18:25
  • @kiamlaluno - I think you should. This is definitely a reproducible problem on the site that you [I] believe is due to a mistake, malfunction, or programming error. I went ahead and edited it, roll back if you don't want it. Also, make sure to use [meta-tag:bug] instead of [tag:bug] when you're referring to tags on MSO, they point to the Stackoverflow tag otherwise. Oct 27, 2011 at 23:06

2 Answers 2


I couldn't reproduce everything you and Kevin describe, but some of it. Should be all fixed in the next build.


You stopped too early! The fun hasn't stopped yet!!

There are actually 5 steps in the process:

  1. Initial state with darkened arrow and previous number (if any) on hover

    enter image description here

  2. The standard number + darkened arrow after clicking "upvote".

    enter image description here

  3. Click the darkened arrow again (I did this all with one post, you had more comments involved). Did you get the "You may only submit a comment vote every 5 seconds" notification?

    • Yes, you get the number + upvote link

      enter image description here

    • No, GOTO 6

  4. Click the upvote link for removed numbers and a darkened arrow where the numbers used to be

    enter image description here

  5. Click the darkened arrow for an upvote link and still no numbers

    enter image description here

  6. Click the upvote link for a darkened arrow and still no numbers. GOTO 5

    enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .